View Issue Details

IDProjectCategoryView StatusLast Update
0000078easycwmpGeneralpublic2015-08-27 22:18
Reportermariofur Assigned Tomohamed.kallel  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformLinuxOSUbuntuOS Version14.04
Summary0000078: Error when "make" libubox.
DescriptionHi All.
I've been trying to install like documentation says, but I get an error when I try to "make" the "libubox". This error says specifically this:" In function '__blobmsg_add_json':" and in the next line I see:"error: implicit declaration of funcition 'is_error' [-Werror=implicit-function-declaration]"

Could someone help me???

Thanks in advance.
Steps To Reproducegeneral

easycwmp will be placed in /opt/dev/ directory. All other dependencies will be installed in /opt/git/ directory.

Configure USER and GROUP variables that we are going to use:

USER=your_user
GROUP=your_group

Create directories:

sudo mkdir -p /opt/{dev,git}
sudo chown -R $USER:$GROUP /opt/{dev,git}

 

curl

Your distribution should already have curl development package. Use that for now.

 

json-c

git clone git://github.com/json-c/json-c.git /opt/git/json-c
cd /opt/git/json-c/

Generate configuration files:

autoreconf -i

Configure:

./configure --prefix=/usr

Build:

make

Install:

sudo make install
sudo ln -sf /usr/include/json-c /usr/include/json

 

libubox

Get the sources:

git clone git://nbd.name/luci2/libubox.git /opt/git/libubox
cd /opt/git/libubox/

Configure:

cmake CMakeLists.txt -DBUILD_LUA=OFF

Build:

make
TagsNo tags attached.

Activities

mohamed.kallel

2015-08-26 23:41

administrator   ~0000272

This is because you are building libubox with a newest version of json-c.
try to rebuild json-c with version 0.11
or contact the libubox guys

mariofur

2015-08-27 17:13

reporter   ~0000273

That's it. Thanx for your help!

Issue History

Date Modified Username Field Change
2015-08-26 17:00 mariofur New Issue
2015-08-26 23:41 mohamed.kallel Note Added: 0000272
2015-08-27 17:13 mariofur Note Added: 0000273
2015-08-27 22:18 mohamed.kallel Status new => resolved
2015-08-27 22:18 mohamed.kallel Resolution open => no change required
2015-08-27 22:18 mohamed.kallel Assigned To => mohamed.kallel