View Issue Details

IDProjectCategoryView StatusLast Update
0000229easycwmpBugpublic2017-05-25 10:43
Reporterandy_yang Assigned ToAnis  
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformopenwrt15OSlinuxOS Versionlinux
Summary0000229: system reboot constantly by running command "easycwmpd start" or "easycwmpd boot"
Descriptionrun easycwmpd program in the openwrt15, the console don't have log message,and the CPE reboot constantly.
Steps To Reproduce1. I have install easycwmp-openwrt-1.5.2.tar.gz by Official manual
2. run easycwmp by following command
root@Openwrt:/usr/sbin# easycwmpd start
root@Openwrt:/usr/sbin#
root@Openwrt:/usr/sbin#

3.another console ,we can see the easycwmpd process status of the CPE:

root@Openwrt:~# ps | grep easycwmp
 3400 root 1920 S /usr/sbin/easycwmpd -f --boot
 3655 root 1556 S {easycwmp} /bin/sh /usr/sbin/easycwmp --json-input
 3863 root 1348 S grep easycwmp
root@Openwrt:~# ps | grep easycwmp
root@Openwrt:~# ps | grep easycwmp
 3917 root 1348 S grep easycwmp
root@Openwrt:~#

4. for a few seconds, we find the CPE reboot constantly
root@EBANG:/usr/sbin# [ 137.230000] save exit: isCheckpointed 1
[ 138.790000] br-lan: port 1(eth1.1) entering disabled state
[ 138.790000] device eth1.1 left promiscuous mode
[ 138.800000] device eth1 left promiscuous mode
[ 138.800000] br-lan: port 1(eth1.1) entering disabled state
[ 138.820000] ADDRCONF(NETDEV_UP): eth1.1: link is not ready
[ 139.930000]
[ 139.930000] mv_eth_txq_cpu_clean: port=0, txp=0, txq=0, mode=CPU
[ 139.930000] Free 0 buffers: from desc=1507 to desc=1507, tx_count=0
[ 139.940000] eth1: stopped
[ 141.270000] save exit: isCheckpointed 1
[ 141.290000] save exit: isCheckpointed 1
[ 141.310000] save exit: isCheckpointed 1
[ 144.360000] Shutting Down Marvell Ethernet Driver
[ 144.360000] Restarting system.
[ 144.360000] Reseting !!

BootROM 1.34
Booting from NAND flash
BootROM: Image checksum verification PASSED
.....
.....
Additional Informationplease refer to attatchment.
The console_1 and console_2 is the same CPE meanwhile.
TagsNo tags attached.

Activities

andy_yang

2017-05-22 11:35

reporter  

console.rar (78,482 bytes)

mohamed.kallel

2017-05-23 19:16

administrator   ~0000700

Please check you acs, may be your acs is sending reboot method to the easycwmp

mohamed.kallel

2017-05-23 19:16

administrator   ~0000701

You can see the log of easycwmp with logread command

andy_yang

2017-05-24 04:45

reporter   ~0000702

The console log stop at entering main loop, can you give me the conclustion?
root@EBANG:~# easycwmpd boot
2017-05-24 10:46:32 [easycwmp] NOTICE - external script init
config_init_local(55):: easycwmp.@local[0].interface=eth1.4093
config_init_local(65):: easycwmp.@local[0].port=7547
config_init_local(83):: easycwmp.@local[0].ubus_socket=/var/run/ubus.sock
config_init_local(94):: easycwmp.@local[0].logging_level=3
config_init_local(71):: easycwmp.@local[0].username=rms61391322
config_init_local(77):: easycwmp.@local[0].password=rms37117846
config_init_acs(159):: easycwmp.@acs[0].url=http://192.168.4.11:9090/ACS-server/ACS
config_init_acs(177):: easycwmp.@acs[0].periodic_enable=1
config_init_acs(183):: easycwmp.@acs[0].periodic_interval=100
config_init_acs(190):: easycwmp.@acs[0].periodic_time=0001-01-01T00:00:00Z
config_init_acs(165):: easycwmp.@acs[0].username=cpe12693157
config_init_acs(171):: easycwmp.@acs[0].password=cpe69156167
2017-05-24 10:46:32 [easycwmp] NOTICE - init periodic inform: reference time = n/a, interval = 100
2017-05-24 10:46:32 [easycwmp] NOTICE - external: execute update_value_change
2017-05-24 10:46:32 [easycwmp] NOTICE - daemon started
2017-05-24 10:46:32 [easycwmp] NOTICE - external: execute inform device_id
2017-05-24 10:46:32 [easycwmp] NOTICE - external script exit
2017-05-24 10:46:32 [easycwmp] NOTICE - interface eth1.4093 has ip 192.168.20.99
+++ HTTP SERVER CONFIGURATION +++
ip: '192.168.20.99'
port: '7547'
--- HTTP SERVER CONFIGURATION ---
2017-05-24 10:46:32 [easycwmp] NOTICE - http server initialized
root@EBANG:~# 2017-05-24 10:46:32 [easycwmp] NOTICE - entering main loop

andy_yang

2017-05-24 04:48

reporter   ~0000703

By the way, I don't know why the ACS send reboot method? I have use the ACS to test other CPE running other tr069 program, the CPE don't receive the reboot method from ACS.

andy_yang

2017-05-24 05:57

reporter   ~0000704

I have find the key of the problem.
I use the two acs, the one URL is http://192.168.4.11:9090/ACS-server/ACS.
Another is http://192.168.20.36:80/acs. The former URL is not OK. I think the reasion it the special character "-" in the path of ACS-server/ACS.
so, your idea? can you help me check the code together?

andy_yang

2017-05-24 06:00

reporter   ~0000705

It seems that the special character "-" in the path of /ACS-server/ACS cause above reboot method from acs or other strange issue.

Anis

2017-05-24 12:27

developer   ~0000706

if the ACS url is wrong the easycwmp can not connect to the ACS server and could not be the cause of reboot.
if you want to be sure if the reboot is caused by ACS or not, you have see the traffic between Easycwmp and your ACS.

maybe it is hardware watchdog which causes this issue.

check the log of dmesg command before reboot !

andy_yang

2017-05-25 02:51

reporter   ~0000707

Thanks, the reboot is caused by ACS. I have restore my acs's environment

Issue History

Date Modified Username Field Change
2017-05-22 11:35 andy_yang New Issue
2017-05-22 11:35 andy_yang File Added: console.rar
2017-05-23 19:16 mohamed.kallel Note Added: 0000700
2017-05-23 19:16 mohamed.kallel Note Added: 0000701
2017-05-24 04:45 andy_yang Note Added: 0000702
2017-05-24 04:48 andy_yang Note Added: 0000703
2017-05-24 05:57 andy_yang Note Added: 0000704
2017-05-24 06:00 andy_yang Note Added: 0000705
2017-05-24 12:27 Anis Note Added: 0000706
2017-05-25 02:51 andy_yang Note Added: 0000707
2017-05-25 10:42 Anis Status new => resolved
2017-05-25 10:42 Anis Resolution open => fixed
2017-05-25 10:42 Anis Assigned To => Anis