View Issue Details

IDProjectCategoryView StatusLast Update
0000002easycwmpHelppublic2014-05-26 10:17
Reporterwind.shen Assigned ToAnis  
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformFreescale P1020RDB easyCwmp OSopenWRT- Linux, gcc 4.6.4OS Version3.10.18
Summary0000002: No any data model tree of InternetGatewayDevice.* as connecting openACS
DescriptionACS : openacs-vmware
(http://sourceforge.net/projects/openacs/files/openacs-vmware/)

cwmp client : EasyCwmp 1.0 on openWRT
(http://easycwmp.org/index.php/manual)


Steps To ReproduceEasyCwmp can connect openACS, and get some value (sw, hw, sn connectURL) from overview page (http://192.168.1.96:8080/openacs/cpe_overview.jsf).

Then, check CWMP tree page (http://192.168.1.96:8080/openacs/cpe_cwmptree.jsf).
It will be shown "No saved values found. Check settings in profile or wait for device contacting ACS."

If you need some information, please tell me.

notes: using fishcorecpe to connect openACS, it is ok to show cwmp tree.

thanks,
Wind.Shen
TagsNo tags attached.

Activities

Anis

2014-05-12 11:50

developer   ~0000001

could you please describe more the steps to reproduce this issue !

wind.shen

2014-05-12 12:10

reporter   ~0000002

hi,

I need CWMP tree to list parameters of the Freescale P1020RDB.

When using easyCwmp or freeCwmp built in P1020RDB,
I cannot see any CWMP tree on openACS page.

Do you have any successful case for my reference?

Anis

2014-05-12 12:34

developer   ~0000003

If you means to list parameters of the "Freescale P1020RDB" board then you have to add Freescale's parameters in the data model script.

else when you launch easycwmp with command start (/etc/init.d/easycwmpd start)
OpenACS recognise the easycwmp device and then update its data base with the parameters (already exist in data model)and you could see cwmp tree of "InternetGatewayDevice." for exemple.

Anis

2014-05-12 14:59

developer   ~0000004

wait for information about parameters list (objects and parameters of data model)

wind.shen

2014-05-13 10:39

reporter  

openACS-1.JPG (105,270 bytes)   
openACS-1.JPG (105,270 bytes)   

wind.shen

2014-05-13 10:41

reporter  

openACS-4.JPG (95,797 bytes)   
openACS-4.JPG (95,797 bytes)   

wind.shen

2014-05-13 10:42

reporter  

openACS-3.JPG (46,570 bytes)   
openACS-3.JPG (46,570 bytes)   

wind.shen

2014-05-13 10:44

reporter   ~0000005

I have lanched easycwmp and OpenACS can recognise the easycwmp device successfully.

I only modified /etc/config/easycwmp and can get the value of easycwmp device from OpenACS. As snapshot file - openACS-1.jpg

CWMP parameters as openACS-4.jpg, CWMP tree as openACS-3.jpg.

Could you tell teach me how to get values of data model ?
thanks

Anis

2014-05-16 10:01

developer   ~0000006

Last edited: 2014-05-16 18:23

to get the cwmp value tree follow these steps :

1 step )
==> Run openacs

2 step )
==> check the config of the CPE (/etc/config/easycwmp)[ACS @ and path]:
 
config local
        option interface 'eth0'
        option port '7547'
        option ubus_socket '/var/run/ubus.sock'
        option date_format '%FT%T%z'
        option username 'easycwmp'
        option password 'easycwmp'

config acs
        option scheme 'http'
        option port '8080'
        option path '/openacs/acs'
        option periodic_enable '1'
        option hostname '192.168.1.159'
        option username 'admin'
        option password 'openacs'
        option periodic_interval '1800'
        option parameter_key 'unsetCommandKey'

config device
        option manufacturer 'easycwmp'
        option oui 'FFFFFF'
        option product_class 'easycwmp'
        option serial_number 'FFFFFF123456'
        option hardware_version 'example_hw_version'
        option software_version 'example_sw_version'

config scripts
        list location '/lib/functions/network.sh'
        list location '/usr/share/easycwmp/functions/common'
        list location '/usr/share/easycwmp/functions/device_info'
        list location '/usr/share/easycwmp/functions/lan_device'
        list location '/usr/share/easycwmp/functions/management_server'
        list location '/usr/share/easycwmp/functions/wan_device'
        list function 'device_info'
        list function 'lan_device'
        list function 'management_server'
        list function 'wan_device'

config notifications

3 step )
==>
 * Run the CPE with command : /etc/init.d/easycwmpd start
 * Check the end of session (204 No Content)
 
4 step )
==> Check CWMP value tree


I tested with openacs-vmware and it works. see attached picture "cpe_cwmp_tree.JPG"

If the problem persists please send us the traffic log (pcap file)

Anis

2014-05-16 18:22

developer  

cpe_cwmp_tree.JPG (74,358 bytes)   
cpe_cwmp_tree.JPG (74,358 bytes)   

Anis

2014-05-16 18:22

developer  

cpe_find.JPG (63,655 bytes)   
cpe_find.JPG (63,655 bytes)   

Anis

2014-05-16 18:22

developer  

cpe_find_device.JPG (113,858 bytes)   
cpe_find_device.JPG (113,858 bytes)   

wind.shen

2014-05-20 04:50

reporter   ~0000008

Last edited: 2014-05-20 04:52

Hi,
The console log as follow:


root@OpenWrt:/# /etc/init.d/easycwmpd stop
root@OpenWrt:/# /etc/init.d/easycwmpd start
config_init_local(53):: easycwmp.@local[0].interface=br-lan
config_init_local(63):: easycwmp.@local[0].port=7547
config_init_local(81):: easycwmp.@local[0].ubus_socket=/var/run/ubus.sock
config_init_acs(147):: easycwmp.@acs[0].scheme=http
config_init_acs(153):: easycwmp.@acs[0].username=admin
config_init_acs(159):: easycwmp.@acs[0].password=openacs
config_init_acs(165):: easycwmp.@acs[0].hostname=192.168.1.236
config_init_acs(175):: easycwmp.@acs[0].port=8080
config_init_acs(181):: easycwmp.@acs[0].path=/openacs/acs
config_init_acs(187):: easycwmp.@acs[0].periodic_enable=1
config_init_acs(193):: easycwmp.@acs[0].periodic_interval=100
+++ HTTP SERVER CONFIGURATION +++
ip: '192.168.1.1'
port: '7547'
--- HTTP SERVER CONFIGURATION ---
root@OpenWrt:/# +++ HTTP CLIENT CONFIGURATION +++
http_client_init(49):: url: http://admin:openacs@192.168.1.236:8080/openacs/acs
http_client_init(55):: ssl_verify: SSL certificate validation disabled.
--- HTTP CLIENT CONFIGURATION ---
> POST /openacs/acs HTTP/1.1
Host: 192.168.1.236:8080
Accept: */*
User-Agent: easycwmp
Content-Type: text/xml
Content-Length: 3059
Expect: 100-continue

< HTTP/1.1 100 Continue
< HTTP/1.1 401 Unauthorized
< Server: Apache-Coyote/1.1
< X-Powered-By: Servlet 2.4; JBoss-4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)/JBossWeb-2.0
< Set-Cookie: JSESSIONID=4F0538F0D816B4E784410ECAF7CA8C3D; Path=/
< WWW-Authenticate: Basic realm="OpenACS"
< Content-Type: text/html;charset=utf-8
< Content-Length: 948
< Date: Tue, 20 May 2014 02:45:20 GMT
<
> POST /openacs/acs HTTP/1.1
Authorization: Basic YWRtaW46b3BlbmFjcw==
Host: 192.168.1.236:8080
Accept: */*
User-Agent: easycwmp
Content-Type: text/xml
Content-Length: 3059
Expect: 100-continue

< HTTP/1.1 100 Continue
< HTTP/1.1 200 OK
< Server: Apache-Coyote/1.1
< X-Powered-By: Servlet 2.4; JBoss-4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)/JBossWeb-2.0
< Set-Cookie: JSESSIONID=367C2A4F772E865C85C501FD43C058E4; Path=/
< Content-Type: text/xml
< Content-Length: 611
< Date: Tue, 20 May 2014 02:45:20 GMT
<
+++ RECEIVED HTTP RESPONSE (PART) +++
<SOAP-ENV:Envelope xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:cwmp="urn:dslforum-org:cwmp-1-0" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><SOAP-ENV:Header><cwmp:ID SOAP-ENV:mustUnderstand="1">ID:intrnl.unset.id.Inform1400557520154.17489899</cwmp:ID><cwmp:NoMoreRequests>0</cwmp:NoMoreRequests></SOAP-ENV:Header><SOAP-ENV:Body><cwmp:InformResponse xmlns:cwmp="urn:dslforum-org:cwmp-1-0"><MaxEnvelopes>1</MaxEnvelopes></cwmp:InformResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>--- RECEIVED HTTP RESPONSE (PART) ---
+++ RECEIVED HTTP RESPONSE +++
<SOAP-ENV:Envelope xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:cwmp="urn:dslforum-org:cwmp-1-0" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><SOAP-ENV:Header><cwmp:ID SOAP-ENV:mustUnderstand="1">ID:intrnl.unset.id.Inform1400557520154.17489899</cwmp:ID><cwmp:NoMoreRequests>0</cwmp:NoMoreRequests></SOAP-ENV:Header><SOAP-ENV:Body><cwmp:InformResponse xmlns:cwmp="urn:dslforum-org:cwmp-1-0"><MaxEnvelopes>1</MaxEnvelopes></cwmp:InformResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>--- RECEIVED HTTP RESPONSE ---
> POST /openacs/acs HTTP/1.1
Authorization: Basic YWRtaW46b3BlbmFjcw==
Host: 192.168.1.236:8080
Accept: */*
User-Agent: easycwmp
Content-Type: text/xml
Content-Length: 501

< HTTP/1.1 200 OK
< Server: Apache-Coyote/1.1
< X-Powered-By: Servlet 2.4; JBoss-4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)/JBossWeb-2.0
< Set-Cookie: JSESSIONID=FBB1999ED143121025B5E5B72B705296; Path=/
< Content-Type: text/xml
< Content-Length: 0
< Date: Tue, 20 May 2014 02:45:20 GMT
<
+++ RECEIVED EMPTY HTTP RESPONSE +++
> POST /openacs/acs HTTP/1.1
Authorization: Basic YWRtaW46b3BlbmFjcw==
Host: 192.168.1.236:8080
Accept: */*
User-Agent: easycwmp
Content-Type: text/xml
Content-Length: 0

< HTTP/1.1 500 Internal Server Error
< Server: Apache-Coyote/1.1
< Content-Type: text/html;charset=utf-8
< Content-Length: 1552
< Date: Tue, 20 May 2014 02:45:20 GMT
< Connection: close
<
+++ RECEIVED HTTP RESPONSE (PART) +++
<html><head><title>JBossWeb/2.0.1.GA - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 500 - </h1><HR size="1" noshade="noshade">

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.NullPointerException
        org.openacs.ACSServlet.RunConfigurator(ACSServlet.java:632)
        org.openacs.ACSServlet.processRequest(ACSServlet.java:522)
        org.openacs.ACSServlet.doPost(ACSServlet.java:609)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)

note The full stack trace of the root cause is available in the JBossWeb/2.0.1.GA logs.

<HR size="1" noshade="noshade"><h3>JBossWeb/2.0.1.GA</h3></body></html>--- RECEIVED HTTP RESPONSE (PART) ---
cwmp_handle_messages(347): sending http message failed
cwmp_inform(311): handling xml message failed


The traffic log (openacs-http-dump.pcapng) as the attachment.

thanks your help

wind.shen

2014-05-20 04:51

reporter  

openacs-http-dump.pcapng (272,592 bytes)

wind.shen

2014-05-20 04:58

reporter   ~0000009

hi Anis,

Could you send me the daemon - easycwmpd to test on my environment.

thanks

wind.shen

2014-05-20 09:31

reporter   ~0000010

Hi Anis,

please skip the console log.
Could you provide us with the configure option?

my configure is as the following.

./configure --target=powerpc-openwrt-linux' '--host=powerpc-openwrt-linux' '--build=i486-linux-gnu' '--program-prefix=' '--program-suffix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib' '--sysconfdir=/etc' '--datadir=/usr/share' '--localstatedir=/var' '--mandir=/usr/man' '--infodir=/usr/info' '--disable-nls' '--with-uci-include-path=/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/include' '--with-libubox-include-path=/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/include' '--with-libubus-include-path=/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/include' '--enable-acs=multi' '--enable-debug' '--enable-devel' '--enable-jsonc=1' 'build_alias=i486-linux-gnu' 'host_alias=powerpc-openwrt-linux' 'target_alias=powerpc-openwrt-linux' 'CC=powerpc-openwrt-linux-uclibcspe-gcc' 'CFLAGS=-Os -pipe -mcpu=8540 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -D_GNU_SOURCE ' 'LDFLAGS=-L/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/lib -L/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/lib -L/home/wind/OpenWrt/openwrt_main/staging_dir/toolchain-powerpc_8540_gcc-4.6-linaro_uClibc-0.9.33.2/usr/lib -L/home/wind/OpenWrt/openwrt_main/staging_dir/toolchain-powerpc_8540_gcc-4.6-linaro_uClibc-0.9.33.2/lib -Wl,-rpath-link=/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/lib ' 'CPPFLAGS=-I/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/include -I/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/include -I/home/wind/OpenWrt/openwrt_main/staging_dir/toolchain-powerpc_8540_gcc-4.6-linaro_uClibc-0.9.33.2/usr/include -I/home/wind/OpenWrt/openwrt_main/staging_dir/toolchain-powerpc_8540_gcc-4.6-linaro_uClibc-0.9.33.2/include ' 'PKG_CONFIG=/home/wind/OpenWrt/openwrt_main/staging_dir/host/bin/pkg-config' 'PKG_CONFIG_PATH=/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/lib/pkgconfig' 'PKG_CONFIG_LIBDIR=/home/wind/OpenWrt/openwrt_main/staging_dir/target-powerpc_8540_uClibc-0.9.33.2/usr/lib/pkgconfig

Anis

2014-05-22 16:35

developer   ~0000012

Last edited: 2014-05-22 16:40

Hi wind.shen,
I recognise from the traffic log (openacs-http-dump.pcapng )that the session between ACS and CPE has not terminated well.
for this reason ACS doesn't show cwmp tree.
I have done this test with 2 kind of device:
->Target system Broadcom BCM63xx_ref_nand
->Target system x86

but I can't reproduce your problem !

Anis

2014-05-22 16:41

developer   ~0000013

I see in ./configure script that you compile OpenWrt with Target System MPC85xx.
have you compiled a OpenWrt Attitude Adjustment with EasyCwmp built-in with this Target System(MPC85xx)?

And what kind of device you use ?

wind.shen

2014-05-23 05:18

reporter   ~0000014

Hi Anis,

I have seen CWMP tree on openACS page sucessfully.
Possible Cause:
1. EasyCwmp cannot built in 64 btis OS.
(I havd tried it in ubuntu 10.04 and 14.04 64 bits.)
2. CWMP tree need some time to be shown on the page.
3. remove username/ password in config.

thanks your help
you can close this issue.

Issue History

Date Modified Username Field Change
2014-05-09 03:41 wind.shen New Issue
2014-05-12 11:50 Anis Note Added: 0000001
2014-05-12 12:10 wind.shen Note Added: 0000002
2014-05-12 12:34 Anis Note Added: 0000003
2014-05-12 14:54 Anis Assigned To => Anis
2014-05-12 14:54 Anis Priority high => low
2014-05-12 14:54 Anis Status new => assigned
2014-05-12 14:54 Anis Description Updated
2014-05-12 14:59 Anis Note Added: 0000004
2014-05-12 14:59 Anis Status assigned => feedback
2014-05-13 10:39 wind.shen File Added: openACS-1.JPG
2014-05-13 10:41 wind.shen File Added: openACS-4.JPG
2014-05-13 10:42 wind.shen File Added: openACS-3.JPG
2014-05-13 10:44 wind.shen Note Added: 0000005
2014-05-13 10:44 wind.shen Status feedback => assigned
2014-05-14 12:48 administrator Category General => Help
2014-05-16 10:01 Anis Note Added: 0000006
2014-05-16 10:01 Anis Note Edited: 0000006
2014-05-16 10:29 Anis Note Edited: 0000006
2014-05-16 11:56 Anis Note Edited: 0000006
2014-05-16 11:57 Anis Note Edited: 0000006
2014-05-16 12:30 Anis Note Edited: 0000006
2014-05-16 12:30 Anis Note Edited: 0000006
2014-05-16 12:31 Anis Note Edited: 0000006
2014-05-16 18:22 Anis File Added: cpe_cwmp_tree.JPG
2014-05-16 18:22 Anis File Added: cpe_find.JPG
2014-05-16 18:22 Anis File Added: cpe_find_device.JPG
2014-05-16 18:23 Anis Note Edited: 0000006
2014-05-20 04:50 wind.shen Note Added: 0000008
2014-05-20 04:51 wind.shen File Added: openacs-http-dump.pcapng
2014-05-20 04:52 wind.shen Note Edited: 0000008
2014-05-20 04:58 wind.shen Note Added: 0000009
2014-05-20 09:31 wind.shen Note Added: 0000010
2014-05-22 16:35 Anis Note Added: 0000012
2014-05-22 16:40 Anis Note Edited: 0000012
2014-05-22 16:40 Anis Note Edited: 0000012
2014-05-22 16:41 Anis Note Added: 0000013
2014-05-23 05:18 wind.shen Note Added: 0000014
2014-05-26 10:17 Anis Status assigned => resolved
2014-05-26 10:17 Anis Resolution open => fixed