View Issue Details

IDProjectCategoryView StatusLast Update
0000016easycwmpQuestionpublic2014-10-10 16:47
Reporterhlee Assigned ToAnis  
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformopenWRT - AAOSLinuxOS Version2.6.36
Summary0000016: in script /usr/sbin/easycwmp
Descriptionthe script seems always in the while loop:

        while read CMD; do
            [ -z "$CMD" ] && continue
            json_get_opt "$CMD"
            handle_action
        done

because CMD was not defined. Where did CMD get defined?

Thanks.
TagsNo tags attached.

Activities

mohamed.kallel

2014-10-09 09:31

administrator   ~0000074

CMD is got from

     while read CMD; do

it's got from stdin. and in C we make a pipe to the stdin in order to send data (commands) to the script

Issue History

Date Modified Username Field Change
2014-10-09 01:48 hlee New Issue
2014-10-09 09:31 mohamed.kallel Note Added: 0000074
2014-10-09 09:31 mohamed.kallel Priority high => none
2014-10-09 09:31 mohamed.kallel Severity major => minor
2014-10-10 16:47 Anis Status new => resolved
2014-10-10 16:47 Anis Resolution open => fixed
2014-10-10 16:47 Anis Assigned To => Anis