View Issue Details

IDProjectCategoryView StatusLast Update
0000013easycwmpHelppublic2014-09-30 09:58
ReporterCwmpUser Assigned ToAnis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformopenwrt 
Summary0000013: Cannot get IP address
DescriptionI use get value command to get "InternetGatewayDevice.WANDevice.1.WANConnectionDevice.1.WANIPConnection.1.ExternalIPAddress", which turns out to be empty, also I can't see AP'IP on server. Is this suppose to be like this? Thanks in advance!
TagsNo tags attached.

Activities

CwmpUser

2014-09-26 21:46

reporter  

2014-09-26 15.44.30.jpg (4,319,595 bytes)

CwmpUser

2014-09-26 21:47

reporter  

2014-09-26 15.44.48.jpg (2,701,850 bytes)

mohamed.kallel

2014-09-29 10:28

administrator   ~0000056

Last edited: 2014-09-29 10:29

You have to update the wan_device script.
The wan_device script is under the "ext/openwrt/scripts/functions/" in the source code. And its under "/usr/share/easycwmp/functions" in your openwrt firmware.

In the wan_device script, you have to change the function: "get_wan_device_mng_interface_ip()". you have to change the line: "network_get_ipaddr val mng". Change the "mng" by the name of you wan interface.


The same thing for the "InternetGatewayDevice.WANDevice.1.WANConnectionDevice.1.WANIPConnection.1.MACAddress", you have to change the function "get_wan_device_mng_interface_mac()". you have to change the "val=`$UCI_GET network.mng.macaddr`" by "val=`$UCI_GET network.<your_wan_interface>.macaddr`"

Issue History

Date Modified Username Field Change
2014-09-26 21:46 CwmpUser New Issue
2014-09-26 21:46 CwmpUser File Added: 2014-09-26 15.44.30.jpg
2014-09-26 21:47 CwmpUser File Added: 2014-09-26 15.44.48.jpg
2014-09-29 10:28 mohamed.kallel Note Added: 0000056
2014-09-29 10:29 mohamed.kallel Note Edited: 0000056
2014-09-30 09:58 Anis Status new => resolved
2014-09-30 09:58 Anis Resolution open => fixed
2014-09-30 09:58 Anis Assigned To => Anis