View Issue Details

IDProjectCategoryView StatusLast Update
0000012easycwmpHelppublic2016-04-18 14:51
ReporterCwmpUser Assigned Tomohamed.kallel  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformopenwrtOSubuntu 
Summary0000012: Unable to set parameter value remotely
Description       I use genieacs to set parameter of SSID remotely and on server side, it says 202(task accepted and will be executed later). But on the AP side, I got the following info:

+++ RECEIVED HTTP REQUEST +++
http_digest_auth_fail_response(322):: http_digest_auth_fail_response: header: Digest realm="realm@easycwmp",qop="auth",nonce="32774ffb30cb825ba5c1e48bec3259e9000022ef",opaque="328458fab28345ae87ab3210a8513b14eff452a2"--- RECEIVED HTTP REQUEST ---
+++ HTTP SERVER CONNECTION FAILED +++
+++ RECEIVED HTTP REQUEST +++
http_digest_auth_fail_response(322):: http_digest_auth_fail_response: header: Digest realm="realm@easycwmp",qop="auth",nonce="b45f58b3b96b680f3acc208b189b64220000231f",opaque="328458fab28345ae87ab3210a8513b14eff452a2"--- RECEIVED HTTP REQUEST ---
+++ HTTP SERVER CONNECTION FAILED +++

I use 'easycwmp --json get value' to get the SSID, nothing changes.
TagsNo tags attached.

Activities

Anis

2014-09-25 16:37

developer   ~0000051

Last edited: 2014-09-25 17:18

I use these steps to reproduce your problem
* set parameter value of SSID remotely with openacs : "InternetGatewayDevice.LANDevice.1.WLANConfiguration.1.SSID"

* get parameter value remotely with ACS and get value using CLI

your issue is not reproduced when I follow those steps !

could you provide me the configuration file of wifi under "/etc/conf/wireless"

could you reproduce this problem using the following CLI ?

root@OpenWrt:~# easycwmp --json set value InternetGatewayDevice.LANDevice.1.WLANConfiguration.1.SSID SSID12
root@OpenWrt:~# easycwmp --json apply
{ "status": "1" }
root@OpenWrt:~# easycwmp --json get value InternetGatewayDevice.LANDevice.1.WLANConfiguration.1.SSID
{ "parameter": "InternetGatewayDevice.LANDevice.1.WLANConfiguration.1.SSID", "fault_code": "", "value": "SSID12", "type": "xsd:string" }
root@OpenWrt:~#

CwmpUser

2014-09-25 17:05

reporter  

wireless (1,126 bytes)   
config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'

config wifi-iface
	option device 'radio0'
	option network 'vlan100'
	option mode 'ap'
	option encryption 'wpa2'
	option server '31.1.1.1'
	option key 'benu123'
	option acct_server '31.1.1.1'
	option acct_secret 'benu123'
	option auth_cache '1'
	option nasid '31.1.1.1'
	option instance '1'
	option ssid 'Happy-100'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'

config wifi-iface
	option device 'radio1'
	option network 'vlan110'
	option mode 'ap'
	option ssid 'HappyOpenWRT-110'
	option encryption 'wpa2'
	option server '31.1.1.1'
	option key 'benu123'
	option acct_server '31.1.1.1'
	option acct_secret 'benu123'
	option auth_cache '1'
	option rsn_preauth '1'
	option nasid '31.1.1.1'
	option benu_cache '1'
	option instance '2'

config wifi-iface
	option device 'radio0'
	option mode 'monitor'
	option instance '3'

config wifi-iface
	option device 'radio1'
	option mode 'monitor'
	option instance '4'

wireless (1,126 bytes)   

CwmpUser

2014-09-25 17:09

reporter   ~0000052

Wireless has been uploaded. If I use CLI to set/get, it works fine. Now I think it may be genieACS's issue. I will keep track of it. Btw, my boss won't let me use openACS but genieACS.

mohamed.kallel

2014-09-25 21:43

administrator   ~0000053

Could you provide a traffic capture (wireshark) of the cwmp session between genieACS and the easycwmp

CwmpUser

2014-09-25 22:19

reporter  

AP30.pcap (27,179 bytes)

CwmpUser

2014-09-25 22:22

reporter   ~0000054

Updated. Here is what I did. Do a tcpdump on AP first and then send a setParameterValue request from ACS server. After confirm that the request is completed from server side, I stop the tcpdump. But the package looks a little weird since it seems nothing there about setParameterValues request.

CwmpUser

2014-09-26 21:40

reporter   ~0000055

I figure it out. It's server's problem. Sorry about that.

Issue History

Date Modified Username Field Change
2014-09-25 00:40 CwmpUser New Issue
2014-09-25 16:37 Anis Note Added: 0000051
2014-09-25 17:05 CwmpUser File Added: wireless
2014-09-25 17:09 CwmpUser Note Added: 0000052
2014-09-25 17:18 Anis Note Edited: 0000051
2014-09-25 21:43 mohamed.kallel Note Added: 0000053
2014-09-25 22:19 CwmpUser File Added: AP30.pcap
2014-09-25 22:22 CwmpUser Note Added: 0000054
2014-09-26 21:40 CwmpUser Note Added: 0000055
2014-09-27 15:21 mohamed.kallel Status new => resolved
2014-09-27 15:21 mohamed.kallel Resolution open => fixed
2014-09-27 15:21 mohamed.kallel Assigned To => mohamed.kallel