View Issue Details

IDProjectCategoryView StatusLast Update
0000118easycwmpHelppublic2016-02-26 09:55
Reportersuperkid Assigned Tomohamed.kallel  
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSOpenwrt 
Summary0000118: firmware update, download encounters error
Descriptionkindly help me on this issue, thanks

firmware download on my device encounters internal error as shown in the attached file
easycwmp version 1.2.7,
TagsNo tags attached.

Activities

superkid

2016-02-18 04:57

reporter  

syslog_error (2,520 bytes)   
//

Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.DeviceInfo.SoftwareVersion 
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.DeviceInfo.VendorConfigFile. 
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.ConnectionRequestPassword 
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.ConnectionRequestURL 
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.ConnectionRequestUsername 
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.PeriodicInformInterval 
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: send GetParameterValuesResponse to the ACS
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: received Download method from the ACS
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: add download: delay = 0 sec, url = http://192.168.1.200:80/tr069/file/SOFTWARE/v14.0/"Generic"/easycwmpdev, FileType = '1 Firmware Upgrade Image ', CommandKey = 'v14.0 '
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: send DownloadResponse to the ACS
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: receive empty message from the ACS
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external: execute apply service 
Thu Feb 18 03:31:33 2016 daemon.notice easycwmpd: external script exit
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: end session success
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: start download url = http://192.168.1.200:80/tr069/file/SOFTWARE/v14.0/"Generic"/easycwmpdev, FileType = '1 Firmware Upgrade Image ', CommandKey = 'v14.0 '
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: external script init
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: external: execute download
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: add event '7 TRANSFER COMPLETE'
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: add event 'M Download'
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: download error: 'Internal error'
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: external script exit
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: start session
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: configured acs url http://192.168.1.200:80/tr069
Thu Feb 18 03:31:34 2016 daemon.notice easycwmpd: external script init
syslog_error (2,520 bytes)   

mohamed.kallel

2016-02-18 08:09

administrator   ~0000392

Last edited: 2016-02-18 08:10

Try to execute the following commnds and provide the output

easycwmp download <url> "1 Firmware Upgrade Image" "0" <user_name> <password>
easycwmp apply download "1 Firmware Upgrade Image"

use the right <url>, <user_name>, <password>

superkid

2016-02-19 02:56

reporter   ~0000397

my device's product class is "Generic" and I uploaded an update with v14.07

I found out that the reason it fails is because it was trying to download from this url,

http://192.168.1.200:80/tr069/file/SOFTWARE/14.07/"Generic"/easycwmp

Fixed by changing product class to Generic and uploading a new file for it,

Can you enlighten mo to why it fails to download if product class is "Generic" instead of Generic? Thanks

mohamed.kallel

2016-02-19 08:25

administrator   ~0000398

maybe url containing double quote (") could be the cause of the problem.
Could you confirm that

Issue History

Date Modified Username Field Change
2016-02-18 04:57 superkid New Issue
2016-02-18 04:57 superkid File Added: syslog_error
2016-02-18 08:09 mohamed.kallel Note Added: 0000392
2016-02-18 08:10 mohamed.kallel Note Edited: 0000392
2016-02-19 02:56 superkid Note Added: 0000397
2016-02-19 08:25 mohamed.kallel Note Added: 0000398
2016-02-26 09:55 mohamed.kallel Status new => resolved
2016-02-26 09:55 mohamed.kallel Resolution open => no change required
2016-02-26 09:55 mohamed.kallel Assigned To => mohamed.kallel