View Issue Details

IDProjectCategoryView StatusLast Update
0000102easycwmpBugpublic2015-12-17 14:27
Reporterimuneer Assigned Tomohamed.kallel  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
PlatformOpewrtOSOpenwrtOS Version15.05
Summary0000102: Firmware download fails
DescriptionI have setup FreeACS server to work with EasyCWMP. EasyCWMP is installed in my OpenWRT based CPE. I applied one firmware image from FreeACS to my unit. The problem is, download never completes, the CPE keep failing and creating a loop.

Below is logs from CPE.


=======================
Wed Dec 9 09:29:08 2015 daemon.notice easycwmpd: external script exit
Wed Dec 9 09:29:08 2015 daemon.notice easycwmpd: start session
Wed Dec 9 09:29:08 2015 daemon.notice easycwmpd: configured acs url http://192.168.123.197/tr069
Wed Dec 9 09:29:08 2015 daemon.notice easycwmpd: external script init
Wed Dec 9 09:29:08 2015 daemon.notice easycwmpd: external: execute inform parameter
Wed Dec 9 09:29:08 2015 daemon.notice easycwmpd: send Inform
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: receive InformResponse from the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: send RPC ACS TransferComplete
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: receive TransferCompleteResponse from the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: send empty message to the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: received GetParameterValues method from the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.DeviceInfo.SoftwareVersion
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.DeviceInfo.VendorConfigFile.
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.ConnectionRequestPassword
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.ConnectionRequestURL
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.ConnectionRequestUsername
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute get value InternetGatewayDevice.ManagementServer.PeriodicInformInterval
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: send GetParameterValuesResponse to the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: received Download method from the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: add download: delay = 0 sec, url = http://192.168.123.197:80/tr069/file/SOFTWARE/3.00/Generic/OpenWrt-FFFFFF123456, FileType = '1 Firmware Upgrade Image ', CommandKey = '3.00'
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: send DownloadResponse to the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: receive empty message from the ACS
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute apply service
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external script exit
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: end session success
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: start download url = http://192.168.123.197:80/tr069/file/SOFTWARE/3.00/Generic/OpenWrt-FFFFFF123456, FileType = '1 Firmware Upgrade Image ', CommandKey = '3.00'
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external script init
Wed Dec 9 09:29:09 2015 daemon.notice easycwmpd: external: execute download
Wed Dec 9 09:29:10 2015 daemon.notice easycwmpd: add event '7 TRANSFER COMPLETE'
Wed Dec 9 09:29:10 2015 daemon.notice easycwmpd: add event 'M Download'
Wed Dec 9 09:29:10 2015 daemon.notice easycwmpd: external: execute apply download 1 Firmware Upgrade Image
Wed Dec 9 09:29:10 2015 daemon.notice easycwmpd: download error: 'Invalid arguments'
========================


Problem is, this becomes loop and never ends.

My trouble shootings:
---------------------
I tried downloading the firmware using above mentioned URL with WGET command, it works.
I did a firmware upgrade with the same image using sysupgrade, it works.
Tagsfirmware, provision

Activities

mohamed.kallel

2015-12-09 11:16

administrator   ~0000341

For the issue: "Problem is, this becomes loop and never ends.":

explaination:
1) each time the session finish and then a download failure occur it causes a new event '7 TRANSFER COMPLETE'.
2) the new event will triggir a new session with FreeACS
3) in the new session the FreeACS will ask easycwmp for the download ==> and then repeat the step 1

How to fix it?
You have to configure your ACS to not send a Download request to the easycwmp in the 2nd session

imuneer

2015-12-09 11:37

reporter   ~0000342

OK. I will check in FreeACS if there is any option to disable it.

By the way, what it could be the cause for download failure as long as I can manually download using wget and upgrade using sysupgrade?

mohamed.kallel

2015-12-09 11:38

administrator   ~0000343

Last edited: 2015-12-09 11:41

There is a space at the end of the FileType argument of the download request from the ACS:

'1 Firmware Upgrade Image '

you have to chang it in your ACS

'1 Firmware Upgrade Image'

imuneer

2015-12-09 13:57

reporter   ~0000344

Yes it is,, It does upgrade now. :)

Thank you,

Issue History

Date Modified Username Field Change
2015-12-09 10:32 imuneer New Issue
2015-12-09 10:33 imuneer Tag Attached: firmware
2015-12-09 10:33 imuneer Tag Attached: provision
2015-12-09 11:16 mohamed.kallel Note Added: 0000341
2015-12-09 11:37 imuneer Note Added: 0000342
2015-12-09 11:38 mohamed.kallel Note Added: 0000343
2015-12-09 11:41 mohamed.kallel Note Edited: 0000343
2015-12-09 13:57 imuneer Note Added: 0000344
2015-12-17 14:27 mohamed.kallel Status new => resolved
2015-12-17 14:27 mohamed.kallel Resolution open => no change required
2015-12-17 14:27 mohamed.kallel Assigned To => mohamed.kallel