EasyCwmp

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000345easycwmp[All Projects] Bugpublic2018-07-18 15:052018-07-18 15:53
Reporterpedro.sanchez 
Assigned To 
PriorityhighSeveritycrashReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Summary0000345: Unable to compile OpenWRT package
DescriptionOn a new cloned openwrt repository, i've installed EasyCwmp OpenWRT package (easycwmp-openwrt-1.7.0.tar.gz) but it doest not compiles.

It returns the error "Cannot find appropriate hash command, ensure the provided hash is either a MD5 or SHA256 checksum."
Steps To Reproducemake package/easycwmp/compile V=s
Additional InformationAccording to
https://github.com/openwrt/openwrt/commit/f4b9d9d6f13c898d473ce678234339e4a9dba5b2#diff-37328c94ce7b51e93bffc95f34083ae7 [^]

the following lines fixes it.
make package/easycwmp/download PKG_HASH=skip V=s
make package/easycwmp/check FIXUP=1 V=s

They add the following
PKG_HASH:=b1238970704dcc0384a8f2b059eabf615ce4e2f4584dc281d602cac89e85daa0
line after
PKG_SOURCE_URL:=http://easycwmp.org/download/ [^]

Hash is required since https://github.com/openwrt/openwrt/commit/b30ba14e2a858cfebcfdbc38348ab96a6d179556 [^]

If you don't need checksum verification, you can add PKG_HASH=skip
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000888)
mohamed.kallel (manager)
2018-07-18 15:53

Thank you for the information

- Issue History
Date Modified Username Field Change
2018-07-18 15:05 pedro.sanchez New Issue
2018-07-18 15:53 mohamed.kallel Note Added: 0000888


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker