View Issue Details

IDProjectCategoryView StatusLast Update
0000157easycwmpBugpublic2016-08-16 14:28
Reporterandy_yang Assigned Tomohamed.kallel  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformhuawei itms,OSubuntuOS Versionubuntu
Summary0000157: sending http message failed when I use huawei's itms not openacs
Description1. my easycwmp configure is as following:
root@andy:/home/andy# cat /etc/config/easycwmp

config local
        option interface 'eth0'
        option port '5474'
        option ubus_socket '/var/run/ubus.sock'
        option date_format '%FT%T%z'
        option username 'cpe'
        option password 'password'
        option logging_level '3'

config acs
        option url 'http://192.168.4.11:9090/ACS-server/ACS'
        option username 'acs'
        option password 'password'
        option periodic_enable '1'
        option periodic_time '0001-01-01T00:00:00Z'
        option periodic_interval '1800'
        option parameter_key 'unsetCommandKey'
Steps To Reproduce1. /usr/sbin/ubusd -s /var/run/ubus.sock
2./usr/sbin/easycwmpd -f -b
TagsNo tags attached.

Activities

andy_yang

2016-07-29 11:10

reporter  

error_log_and_pcap.rar (3,107 bytes)

mohamed.kallel

2016-07-29 16:52

administrator   ~0000519

Last edited: 2016-07-29 16:53

According to the log and the capture, It looks that your ACS is not answering to the Inform sent by the EasyCwmp. that's why the EasyCwmp return http message failed after a timeout of 30 seconds.

The reason could be that your ACS does not recognize the "expect 100 continue" http option.
You can avoid the "expect 100 continue" in the http messages sent by EasyCwmp by setting the config:

uci set easycwmp.@acs[0].http100continue_disable=1
uci commit

andy_yang

2016-08-01 03:25

reporter   ~0000520

I have try this method ,but the result is the same error! I think the reason could be the inform content that not meet ACS's report requirement.

andy_yang

2016-08-01 03:30

reporter   ~0000521

By the way, I can use easycwmp to communication with openacs

mohamed.kallel

2016-08-01 10:08

administrator   ~0000522

Is it possible to check your ACS log. And see why the ACS is rejecting the easycwmp inform?

andy_yang

2016-08-04 03:55

reporter   ~0000524

Ok,thanks!

Issue History

Date Modified Username Field Change
2016-07-29 11:10 andy_yang New Issue
2016-07-29 11:10 andy_yang File Added: error_log_and_pcap.rar
2016-07-29 16:52 mohamed.kallel Note Added: 0000519
2016-07-29 16:53 mohamed.kallel Note Edited: 0000519
2016-08-01 03:25 andy_yang Note Added: 0000520
2016-08-01 03:30 andy_yang Note Added: 0000521
2016-08-01 10:08 mohamed.kallel Note Added: 0000522
2016-08-04 03:55 andy_yang Note Added: 0000524
2016-08-16 14:28 mohamed.kallel Status new => resolved
2016-08-16 14:28 mohamed.kallel Resolution open => no change required
2016-08-16 14:28 mohamed.kallel Assigned To => mohamed.kallel