View Issue Details

IDProjectCategoryView StatusLast Update
0000128easycwmpGeneralpublic2016-05-03 16:00
Reporterstone1223 Assigned Tomohamed.kallel  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
OSUbuntu + OpenWRT 
Summary0000128: How to get/set specific parameters remotely?
DescriptionA newbie question.

I have GenieACS on Ubuntu and Easycwmp on Openwrt. The device can be discovered by GenieACS, but I don't know how to get/set parameters, such as SSID, from ACS remotely. It shows no option about it on GenieACS web.

I read http://support.easycwmp.org/view.php?id=12. I can do it on OpenWRT locally by
easycwmp --json set value InternetGatewayDevice.LANDevice.1.WLANConfiguration.1.SSID SSID12.
Though it only applies when I reboot WIFI.

I also read genieacs API ref https://github.com/zaidka/genieacs/wiki/API-Reference. It helps a little, but I still could not read and write SSID.

I wonder know how to get/set parameters remotely. And also, how to add make further development on Easycwmp to get/set specific parameters what I defined?
TagsNo tags attached.

Activities

mohamed.kallel

2016-04-18 16:17

administrator   ~0000420

Last edited: 2016-04-18 16:18

I do not have a much experience with GenieAcs. But I tested EasyCwmp with GenieACS and I can saw the traffic between ACS and CPE. If you have any question about GenieACS how it can make set/get please refer to Zaid the person behind GenieACS.

About you question of apply SSID values, If you are setting SSID parameter with the ACS then the easycwmp will restart WiFi at the end of the session with ACS. And if you are setting SSID parameter with easycwmp command then you have to restart wifi manually.


If you wan to develop more parameters, you can refer to the existing parameters and follow them, It's easy to implement new params

stone1223

2016-05-03 15:47

reporter   ~0000431

Thank you Kallel. I figure out some of the reasons were my GenieACS installation, though I don't know the specific reason. I just reinstalled it and it works.

However, it took me a little time to find out easycwmp/ext/openwrt/script/functions is the part of example code related to openwrt configuations. I hadn't find some tutorials to get start learning easycwmp from beginning. :)

Issue History

Date Modified Username Field Change
2016-04-18 15:08 stone1223 New Issue
2016-04-18 16:17 mohamed.kallel Note Added: 0000420
2016-04-18 16:18 mohamed.kallel Note Edited: 0000420
2016-05-03 15:47 stone1223 Note Added: 0000431
2016-05-03 16:00 mohamed.kallel Status new => resolved
2016-05-03 16:00 mohamed.kallel Resolution open => fixed
2016-05-03 16:00 mohamed.kallel Assigned To => mohamed.kallel