EasyCwmp

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000324easycwmp[All Projects] Helppublic2018-05-17 08:362018-06-28 15:22
ReporterRany.Li 
Assigned Tomohamed.kallel 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformOSOS Version
Summary0000324: easycwmp download
Descriptionwhen i run the :
easycwmp.sh download http://xx.xx.xx.xx/1.bin [^] '1 Firmware Upgrade Image' '0'
the 1.bin will be download successful.

but if i run the easycwmpd -b -f and set the download on ACS server,it will show a
error always:download error: 'Download failure: file corrupted'

but the filepath or filename was same as http://xx.xx.xx.xx/1.bin [^]。

Please help me thanks.
Additional Information<SOAP-ENV:Envelope xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" [^] xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" [^] xmlns:cwmp="urn:dslforum-org:cwmp-1-0" xmlns:xsd="http://www.w3.org/2001/XMLSchema" [^] xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> [^]
        <SOAP-ENV:Header>
                <cwmp:ID SOAP-ENV:mustUnderstand="1">27957</cwmp:ID>
                <cwmp:HoldRequests SOAP-ENV:mustUnderstand="1"/>
        </SOAP-ENV:Header>
        <SOAP-ENV:Body>
                <cwmp:Download>
                        <CommandKey/>
                        <FileType>1 Firmware Upgrade Image</FileType>
                        <URL>http://xx.xx.xx.xx/1.bin</URL> [^]
                        <Username>username</Username>
                        <Password>password</Password>
                        <FileSize/>
                        <TargetFileName/>
                        <DelaySeconds>0</DelaySeconds>
                        <SuccessURL/>
                        <FailureURL/>
                </cwmp:Download>
        </SOAP-ENV:Body>
</SOAP-ENV:Envelope>--- RECEIVED HTTP RESPONSE ---
1970-01-01 00:22:13 [easycwmp] NOTICE - received Download method from the ACS
1970-01-01 00:22:13 [easycwmp] NOTICE - add download: delay = 0 sec, url = http://203.125.11.38:9092/azacs/firmware/test.down, [^] FileType = '1 Firmware Upgrade Image', CommandKey = ''
1970-01-01 00:22:13 [easycwmp] NOTICE - send DownloadResponse to the ACS
+++ SEND HTTP REQUEST +++
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
 <soap_env:Envelope
xmlns:soap_env="http://schemas.xmlsoap.org/soap/envelope/" [^]
xmlns:soap_enc="http://schemas.xmlsoap.org/soap/encoding/" [^]
xmlns:xsd="http://www.w3.org/2001/XMLSchema" [^]
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" [^]
xmlns:cwmp="urn:dslforum-org:cwmp-1-2">
  <soap_env:Header>
   <cwmp:ID soap_env:mustUnderstand="1">27957</cwmp:ID>
  </soap_env:Header>
  <soap_env:Body>
   <cwmp:DownloadResponse>
    <Status>1</Status>
    <StartTime>0001-01-01T00:00:00Z</StartTime>
    <CompleteTime>0001-01-01T00:00:00Z</CompleteTime>
   </cwmp:DownloadResponse>
  </soap_env:Body>
 </soap_env:Envelope>
--- SEND HTTP REQUEST ---
> POST /tr069/acs HTTP/1.1
Authorization: Basic ZmlybXdhcmU6YXp0ZWNoMTIz
Host: 203.125.11.38:8081
Cookie: sprtCpeGuid=cfd87e4b16e13de6aed9a9ac0c55e1ab; sprtDeviceEmptyPost=0; CPEID=FFFFFF-aztech-easy-0A0B0C0D0E0F; sprtHTTP204=true; sprtPeerIP=218.17.133.186
User-Agent: easycwmp
Content-Type: text/xml; charset="utf-8"
SOAPAction:
Content-Length: 668

< HTTP/1.1 204 No Content
< Date: Thu, 17 May 2018 06:18:46 GMT
< Server: Apache/2.2.6 (Fedora)
< Vary: Authorization
< Content-Length: 0
< Content-Type: text/plain; charset=UTF-8
<
+++ RECEIVED EMPTY HTTP RESPONSE +++
1970-01-01 00:22:14 [easycwmp] NOTICE - receive empty message from the ACS
1970-01-01 00:22:14 [easycwmp] NOTICE - external: execute apply service
1970-01-01 00:22:14 [easycwmp] NOTICE - external script exit
1970-01-01 00:22:14 [easycwmp] NOTICE - end session success
1970-01-01 00:22:14 [easycwmp] NOTICE - start download url = http://xx.xx.xx.xx/1.bin, [^] FileType = '1 Firmware Upgrade Image', CommandKey = ''
1970-01-01 00:22:14 [easycwmp] NOTICE - external script init
1970-01-01 00:22:15 [easycwmp] NOTICE - external: execute download
1970-01-01 00:22:37 [easycwmp] NOTICE - add event '7 TRANSFER COMPLETE'
1970-01-01 00:22:37 [easycwmp] NOTICE - add event 'M Download'
../src/external.c : 110 : external_method_fault = (null)
1970-01-01 00:22:37 [easycwmp] NOTICE - external: execute apply download 1 Firmware Upgrade Image
../src/external.c : 110 : external_method_fault = 9018
Test : ../src/cwmp.c : 480
1970-01-01 00:22:38 [easycwmp] NOTICE - download error: 'Download failure: file corrupted'
1970-01-01 00:22:38 [easycwmp] NOTICE - external script exit
1970-01-01 00:22:38 [easycwmp] NOTICE - start session
+++ HTTP CLIENT CONFIGURATION +++
http_client_init(50):: url: http://xx.xx.xx.xx [^]
http_client_init(56):: ssl_verify: SSL certificate validation disabled.
--- HTTP CLIENT CONFIGURATION ---
1970-01-01 00:22:38 [easycwmp] NOTICE - configured acs url http://203.125.11.38:8081/tr069/acs [^]
1970-01-01 00:22:38 [easycwmp] NOTICE - external script init
1970-01-01 00:22:39 [easycwmp] NOTICE - external: execute inform parameter
1970-01-01 00:22:43 [easycwmp] NOTICE - send Inform

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000866)
Rany.Li (reporter)
2018-05-18 08:15
edited on: 2018-05-18 08:16

I found another error:
easycwmp --json-input
easycwmp>
get
Failed to parse message data
/usr/share/easycwmp/functions/jshn.sh: line 179: Test: command not found
easycwmp>
set
Failed to parse message data
/usr/share/easycwmp/functions/jshn.sh: line 179: Test: command not found
command =
easycwmp>
what's wrong with this..
I have test the setvalue or getvalue by ACS Server,and it worked.
so weird..

(0000868)
mohamed.kallel (manager)
2018-05-21 13:15

1) For the download issue. the problem does not come from the download of the file. The file is downloaded successfully. The error come from apply the 1.bin firmware. looks yuor bin file is not a right bin file

2) for the issue you get when typing get and set command in the easycwmp cli, you have to input your command in json format. as the argument indicated "--json-input"
(0000870)
Rany.Li (reporter)
2018-06-01 08:22

Thanks.
i have already solved this problem.you can close this issue.
thanks again.

- Issue History
Date Modified Username Field Change
2018-05-17 08:36 Rany.Li New Issue
2018-05-18 08:15 Rany.Li Note Added: 0000866
2018-05-18 08:16 Rany.Li Note Edited: 0000866 View Revisions
2018-05-21 13:15 mohamed.kallel Note Added: 0000868
2018-06-01 08:22 Rany.Li Note Added: 0000870
2018-06-28 15:22 mohamed.kallel Status new => resolved
2018-06-28 15:22 mohamed.kallel Resolution open => no change required
2018-06-28 15:22 mohamed.kallel Assigned To => mohamed.kallel


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker