EasyCwmp

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000031easycwmp[All Projects] Helppublic2015-01-16 09:442015-03-02 09:01
Reportersinkcup 
Assigned Tomohamed.kallel 
PriorityhighSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformOSOS Version
Summary0000031: I fork this repo on github.com, and change some code, want merge to master, is this github repo active?
Descriptionis this github repo active?
https://github.com/pivasoftware/easycwmp/ [^]

I have write a lot of issue, and complete most of them, want merge to master
https://github.com/pivasoftware/easycwmp/issues [^]

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000136)
mohamed.kallel (manager)
2015-02-25 17:42

Dear sinckup

I answered to your issues and patch request on github.

Please Put your new issues in the futur on this site.
And send your patches to team@easycwmp.org
(0000139)
sinkcup (reporter)
2015-02-26 02:57

github use "fork" and "pull request" for opensource project.
you can find link in every issue. it's the code. you apply it, it will merge into the master.
don't need send the code, you can see it at https://github.com/sinkcup/easycwmp [^]
(0000141)
mohamed.kallel (manager)
2015-02-27 15:15

We made an overview on your changes.
Please find here after our remarks:

1) For the InternetGatewayDevice.User.{i}. We can accept the new User data model, but you have 2 parameters which are not defined in the TR-098. Please change their name by adding a propietary prefix X_EASYCWMP_ORG_EncryptedPassword and X_EASYCWMP_ORG_LastChange
2) /init.d/easycwmpd: for the change_config is customized to your hiwifi router and could not be common for all hardware configs and OpenWRT version. So we can not accept a such modif.
3) common
* We can accept change made to get version and oui but you have to provide a patch based on our latest version (1.1.1).
* The change made to get manufacturer can't be accepted since it use command not common for all hardwares. you are free to adapt the script according to your hardware configuration and the OpenWRT Version. The goal of EasyCwmp Design is to make easy for end-user to make a such modification.

4) device_info
* We can accept change made to add 'InternetGatewayDevice.DeviceInfo.MACAddress' but you have to rename the parameter to X_EASYCWMP_ORG_MACAddress since this param does not exist in the TR-098. And please provide a patch based on our last version 1.1.1
* The change made to get manufacturer, product_class ... can't be accepted since it's not common for all hardware and OpenWrt versions.
5) lan_device
* For the hiwifi code update in the lan is refused. since it's a propietary hiwifi config file and it's not common for all hardwares.

* may be accept get_lan_device_channel InternetGatewayDevice.LANDevice.$1.Channel but you have to add channel in the appropriate path (see TR-098) And please provide a patch based on our last version 1.1.1

6) wan_device
we may accept the function to get ip address and mac address but you have to provide a patch based on our last version 1.1.1

7) easycwmp.sh
* for download, we can exept the change "\tmp" --> "\tmp$". Please provide a patch based on our last version 1.1.1
* for download, we can't accept the change for import and commit ($ORG_FILE_NAME variable)
* For apply download, we can't accept the change (add cron task). We do not see any utility to launch the download after a time via crontab. If a such modif has utility for your hardware please feel free to adapt the script according to your hardware configuration and the OpenWRT Version,
The goal of EasyCwmp Design is to make easy for end-user to make a such modification.

8) General remarks:
* The tabulation and changing parm by param is refused for all. we have our own rules and reason to use tab and not spaces
* you are free to adapt the script according to your hardware configuration and the OpenWRT Version,
The goal of EasyCwmp Design is to make easy for end-user to make a such modification.

- Issue History
Date Modified Username Field Change
2015-01-16 09:44 sinkcup New Issue
2015-02-25 17:42 mohamed.kallel Note Added: 0000136
2015-02-25 17:43 mohamed.kallel Status new => resolved
2015-02-25 17:43 mohamed.kallel Resolution open => no change required
2015-02-25 17:43 mohamed.kallel Assigned To => mohamed.kallel
2015-02-26 02:57 sinkcup Note Added: 0000139
2015-02-26 02:57 sinkcup Status resolved => feedback
2015-02-26 02:57 sinkcup Resolution no change required => reopened
2015-02-27 15:15 mohamed.kallel Note Added: 0000141
2015-03-02 09:01 mohamed.kallel Status feedback => resolved
2015-03-02 09:01 mohamed.kallel Resolution reopened => no change required


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker