EasyCwmp

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000018easycwmp[All Projects] Helppublic2014-10-20 10:242015-01-26 04:17
Reporterjanmus 
Assigned ToAnis 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformARMv5TEJOSLinuxOS Version3.0.8
Summary0000018: Run the easycwmp support RPC method [Upload] problem from OpenACS
DescriptionThe Default script as below:

logger("=======>Upload the configuration file<=======");
var response = cpe.Upload ("daCommand", "3 Vendor Configuration File", "http://192.168.0.140:8080/openacs/", [^] "", "", 24, "upload.conf");
logger ("st =" + response.StartTime + "ct =" + response.CompleteTime + "status =" + response.Status);
logger("=======>END<=======");
--------------------------------------------------------------------------
The output from jboss :

INFO: Request is Inform
INFO: oui=FFFFFF sn=FFFFFF123456 oui=FFFFFF, sn=FFFFFF123456, URL=http://192.168.0.114:7547/, [^] hw=v0.153, sw=v1.553, cfg=null, ProvisioningCode=
INFO: FFFFFF:FFFFFF123456 Configurator::run
INFO: FFFFFF:FFFFFF123456 Backup cwmp tree
INFO: FFFFFF:FFFFFF123456 Configurator::CheckParameters
INFO: oui=FFFFFF sn=FFFFFF123456 Request is GetParameterValuesResponse
INFO: oui=FFFFFF sn=FFFFFF123456 Request is Fault
15:05:32,138 INFO [STDOUT] Fault: CWMP fault cwmp: Invalid parameter name
SEVERE: FFFFFF:FFFFFF123456 FAULT: code=Client msg=CWMP fault ccode=9005 cmsg=Invalid parameter name
INFO: oui=FFFFFF sn=FFFFFF123456 Request is Fault
SEVERE: FFFFFF:FFFFFF123456 FAULT: code=Client msg=CWMP fault ccode=9005 cmsg=Invalid parameter name
INFO: =======>Upload the configuration file<=======
SEVERE: FFFFFF:FFFFFF123456 Run exception: [object Object] line: 0 column: 0


TagsNo tags attached.
Attached Files? file icon test.conf [^] (33 bytes) 2014-10-22 12:43

- Relationships

-  Notes
(0000076)
mohamed.kallel (manager)
2014-10-20 21:44
edited on: 2014-10-20 21:44

Upload method is not supported in easycwmp
Please refer to the http://www.easycwmp.org [^] (chapter "EasyCwmp supported methods") to see all supported methods

(0000077)
janmus (reporter)
2014-10-21 04:25
edited on: 2014-10-21 05:58

OK, I see , Thank you very mush.

Then I try RPC method [download] that has support by easycwmp,
But get some error as below,
I can'nt see the download file(test.conf) from openacs to my device.
--------------------------------------------------------------------------
The Default script as below:

logger ("Configuration file Download STARTING");
var response = cpe.Download ("daCommand", "3 Vendor Configuration File","http://192.168.0.140:8080/openacs/firmware/test.conf", [^] "", "",18,"test.conf");
logger ("st="+response.StartTime+" ct="+response.CompleteTime+" status="+response.Status);
logger ("Configuration file Download DONE");

--------------------------------------------------------------------------
The output from jboss :

INFO: Request is Inform
INFO: oui=FFFFFF sn=FFFFFF123456 oui=FFFFFF, sn=FFFFFF123456,
   URL=http://192.168.0.114:7547/, [^] hw=v0.153, sw=v1.553, cfg=null,
   ProvisioningCode=
INFO: oui=FFFFFF sn=FFFFFF123456 Request is TransferComplete
INFO: oui=FFFFFF sn=FFFFFF123456 TransferComplete:
   cmdkey=daCommand faultcode=9018 faultstring=Download failure: file corrupted
INFO: FFFFFF:FFFFFF123456 Configurator::run
INFO: FFFFFF:FFFFFF123456 Backup cwmp tree
  WARNING: FFFFFF:FFFFFF123456 Configuration script 'OnTransferComplete' not found in db.
INFO: Configuration file Download STARTING
  INFO: oui=FFFFFF sn=FFFFFF123456 Request is DownloadResponse
  INFO: st=0001-01-01T00:00:00Z ct=0001-01-01T00:00:00Z status=1
INFO: Configuration file Download DONE
INFO: uri=/openacs/firmware/test.conf, size=18, ct=null

(0000078)
Anis (developer)
2014-10-22 11:02
edited on: 2014-10-22 11:03

Execute these command :

root@OpenWrt:~#wget -O test.conf http://192.168.0.140:8080/openacs/firmware [^]
/test.conf

root@OpenWrt:~# /sbin/uci import < test.conf

Could you enclose the test.conf file

(0000079)
janmus (reporter)
2014-10-22 12:42

Sure, Please see the attached file.

The test.conf content does not uci format,
So,I got some error as below :

# /sbin/uci import < test.conf
  /sbin/uci: Parse error (invalid command) at line 2, byte 0
(0000081)
Anis (developer)
2014-10-22 15:56

So this is a normal behaviour of EasyCwmp according to TR069 standard.

Please use the right format of the configuration file

- Issue History
Date Modified Username Field Change
2014-10-20 10:24 janmus New Issue
2014-10-20 21:44 mohamed.kallel Note Added: 0000076
2014-10-20 21:44 mohamed.kallel Note Edited: 0000076 View Revisions
2014-10-21 04:25 janmus Note Added: 0000077
2014-10-21 05:58 janmus Note Edited: 0000077 View Revisions
2014-10-22 11:02 Anis Note Added: 0000078
2014-10-22 11:03 Anis Note Edited: 0000078 View Revisions
2014-10-22 12:42 janmus Note Added: 0000079
2014-10-22 12:43 janmus File Added: test.conf
2014-10-22 15:56 Anis Note Added: 0000081
2014-10-22 15:57 Anis Status new => resolved
2014-10-22 15:57 Anis Resolution open => fixed
2014-10-22 15:57 Anis Assigned To => Anis


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker