EasyCwmp

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000175easycwmp[All Projects] Questionpublic2016-11-04 03:222016-11-18 09:31
Reporterleaf_ee 
Assigned Tomohamed.kallel 
PriorityurgentSeveritymajorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformOpenwrt 12.09OSlinuxOS Version3.3.8
Summary0000175: Booting problem with easycwmp-1.1.3
DescriptionI made an image on openwrt 12.09, everything is fine.
But later on I added easycwmp-1.1.3, there are some problems.


The boot info without easycwmp-1.1.3:

//////
Starting kernel ...

[ 0.000000] Linux version 3.3.8 (leaf@leaf) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) 0000002 Wed Sep 21 14:28:35 CST 2016
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 0001974c (MIPS 74Kc)
.
.
.
[ 3.020000] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[ 3.030000] Freeing unused kernel memory: 212k freed
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
[ 8.120000] JFFS2 notice: (459) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 12 of xref (0 dead, 2 orphan) found.
switching to jffs2
- init -

Please press Enter to activate this console. [ 9.810000] register chrdev for leds success!!!
[ 9.920000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[ 9.930000] Backport generated by backports.git backports-20140320-37-g5c33da0
[ 10.080000] cfg80211: Calling CRDA to update world regulatory domain
.
.
.
[ 11.520000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
.
[ 11.630000] nf_conntrack version 0.5.0 (963 buckets, 3852 max)
[ 11.920000] xt_time: kernel timezone is -0000
.
[ 23.060000] br-lan: port 2(wlan0) entered forwarding state
[ 25.060000] br-lan: port 2(wlan0) entered forwarding state

Linkpower login: root
//////



The boot info with easycwmp-1.1.3:

//////
Starting kernel ...

[ 0.000000] Linux version 3.3.8 (leaf@leaf) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) 0000002 Wed Sep 21 14:28:35 CST 2016
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 0001974c (MIPS 74Kc)
.
.
.
[ 3.020000] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[ 3.030000] Freeing unused kernel memory: 212k freed
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
[ 8.000000] JFFS2 notice: (458) jffs2_build_xattr_subsystem: complete building xattr subsystem, 2 of xdatum (0 unchecked, 2 orphan) and 2 of xref (0 dead, 2 orphan) found.
switching to jffs2
- init -

Please press Enter to activate this console. Nov 4 04:11:09 crond[547]: crond: crond (busybox 1.19.4) started, log level 5

(none) login: root
//////



We can see, if boot without easycwmp-1.1.3,
leds,
Backport,
cfg80211,
PPP,
tun,
ip_tables,
NET,
ehci(usb host),
hub(usb),
nf_conntrack,
xt_time,
mmc,
eth0,
eth1,
cfg80211,
br-lan,
all packages/modules will be inited successfully.


but if boot with easycwmp-1.1.3, initing is stuck/or skipped at here:
Nov 4 04:11:09 crond[547]: crond: crond (busybox 1.19.4) started, log level 5



The openwrt is 12.09.
Could anyone help to solve it?
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000571)
leaf_ee (reporter)
2016-11-16 10:53

Now I try to restore my openwrt system to the state before installing easycwmp.
 
I deselected easycwmp and deselected its supported libs - libcurl and libmicroxml (other supported libs are shared with other packages and cannot be deselected). then run "make menuconfig clean" "make".
 
but booting is still stucked at here:

Nov 4 04:11:09 crond[547]: crond: crond (busybox 1.19.4) started, log level 5

Obviously, easycwmp does not directly cause the problem. and our openwrt system cannot be restore, its image size is 64KB larger than once before installing easycwmp.

It should be in the course of installing easycwmp, some unknowed soft module/package was quietly introduced (i.e. busybox function.. just for example). Since I did not save ".config" before installing easycwmp, so I entered menuconfig but cannot find any clue.

How to "make menuconfig" to solve it or any other quick solution?
(0000572)
leaf_ee (reporter)
2016-11-17 04:12

Per my checking with older ".config", three modules were possibly added:

kmod-lib-crc-itu-t
kmod-lib-crc7
zlib

I wonder if zlib couses that problem?
(0000573)
leaf_ee (reporter)
2016-11-18 08:26

Solved!

There is nothing wrong with EasyCwmp.

I copied a script 'boot' from Windows 7 OS, coincidentally in the moment of adding eacycwmp package.

See also:

https://forum.openwrt.org/viewtopic.php?id=49718 [^]

Never copy a linux script directly from Windows OS! Though both look like exactly the same.

- Issue History
Date Modified Username Field Change
2016-11-04 03:22 leaf_ee New Issue
2016-11-16 10:53 leaf_ee Note Added: 0000571
2016-11-17 04:12 leaf_ee Note Added: 0000572
2016-11-18 08:26 leaf_ee Note Added: 0000573
2016-11-18 09:31 mohamed.kallel Status new => resolved
2016-11-18 09:31 mohamed.kallel Resolution open => no change required
2016-11-18 09:31 mohamed.kallel Assigned To => mohamed.kallel


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker