EasyCwmp

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000120easycwmp[All Projects] Questionpublic2016-02-25 03:432016-05-11 13:04
Reporterwonderlive 
Assigned Tomohamed.kallel 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformAT91SAM9OSLinuxOS Version2.6.39
Summary0000120: Can EasyCwmp parse InformResponse xml message with header soapenv from ACS
DescriptionMy CPE received the InformResponse message from ACS.The message like the fowllowing:
--------------------------------------------------
<?xml version="1.0" encoding="utf-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"> [^]
    <soapenv:Body>
        <cwmp:InformResponse xmlns:cwmp="urn:dslforum-org:cwmp-1-0">
            <MaxEnvelopes>1</MaxEnvelopes>
            <SOAP-ENV:SoapHeader xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"> [^]
                <cwmp:ID SOAP-ENV:mustUnderstand="1">6</cwmp:ID>
            </SOAP-ENV:SoapHeader>
        </cwmp:InformResponse>
    </soapenv:Body>
</soapenv:Envelope>
-----------------------------------------------------------
It's so different from the one in the cwmp_response_message.xml file:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<soap_env:Envelope
    xmlns:soap_env="http://schemas.xmlsoap.org/soap/envelope/" [^]
    xmlns:soap_enc="http://schemas.xmlsoap.org/soap/encoding/" [^]
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" [^]
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" [^]
    xmlns:cwmp="urn:dslforum-org:cwmp-1-2">
    <soap_env:Header>
        <cwmp:ID soap_env:mustUnderstand="1"/>
    </soap_env:Header>
    <soap_env:Body/>
</soap_env:Envelope>
TagsNo tags attached.
Attached Files? file icon cpe.pcapng [^] (14,008 bytes) 2016-02-25 03:43

- Relationships

-  Notes
(0000400)
mohamed.kallel (manager)
2016-02-25 23:21

it looks an interoperability bug.

What's your ACS?
(0000402)
wonderlive (reporter)
2016-02-26 08:51

Hi mohamed.kallel,

Do you mean the InformResponse message may be invalid format?
My ACS is eSight.It's a paid software.I haven't got easycwmp's log now.I think it would be helpful,and I will attach it later.

Thanks.
(0000403)
mohamed.kallel (manager)
2016-02-26 09:27

yes, Its better to attach the easycwmp log
(0000404)
wonderlive (reporter)
2016-03-02 07:25

The problem is resolved.the ACS needs Content-Type to be 'text/xml' in the http post header,like the following:

POST /comserver/node1/tr069 HTTP/1.1

Host: 192.168.12.74:38445

User-Agent: easycwmp

Content-Type: text/xml; charset="utf-8"

SOAPAction:

Content-Length: 4305

thank you very much.
(0000472)
mohamed.kallel (manager)
2016-05-11 13:03

According to the standard easycwmp should have the following content type

Content-Type: text/xml; charset="utf-8"

fixed in EasyCwmp-1.2.8

- Issue History
Date Modified Username Field Change
2016-02-25 03:43 wonderlive New Issue
2016-02-25 03:43 wonderlive File Added: cpe.pcapng
2016-02-25 23:21 mohamed.kallel Note Added: 0000400
2016-02-26 08:51 wonderlive Note Added: 0000402
2016-02-26 09:27 mohamed.kallel Note Added: 0000403
2016-03-02 07:25 wonderlive Note Added: 0000404
2016-05-11 13:03 mohamed.kallel Note Added: 0000472
2016-05-11 13:04 mohamed.kallel Status new => resolved
2016-05-11 13:04 mohamed.kallel Resolution open => fixed
2016-05-11 13:04 mohamed.kallel Assigned To => mohamed.kallel


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker