EasyCwmp - easycwmp
View Issue Details
0000358easycwmp[All Projects] Bugpublic2018-09-11 21:532018-09-12 15:39
hendre 
 
normalmajoralways
newopen 
LinuxUbuntu16.04
0000358: ./configure error same issue as http://support.easycwmp.org/view.php?id=119 [^] [http://support.easycwmp.org/view.php?id=119 [^]]
/opt/dev/easycwmp$ autoreconf -V
autoreconf (GNU Autoconf) 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+/Autoconf: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>, [^] <http://gnu.org/licenses/exceptions.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by David J. MacKenzie and Akim Demaille.

hendre@testserver:/opt/dev/easycwmp$ aptitude search libcurl
v libcurl-dev -
v libcurl-dev:i386 -
p libcurl-ocaml - OCaml curl bindings (Runtime Library)
p libcurl-ocaml:i386 - OCaml curl bindings (Runtime Library)
v libcurl-ocaml-7alu7 -
p libcurl-ocaml-dev - OCaml libcurl bindings (Development package)
p libcurl-ocaml-dev:i386 - OCaml libcurl bindings (Development package)
v libcurl-ocaml-dev-7alu7 -
v libcurl-ocaml-dev-oioe7:i386 -
v libcurl-ocaml-oioe7:i386 -
v libcurl-ssl-dev -
v libcurl-ssl-dev:i386 -
i A libcurl3 - easy-to-use client-side URL transfer library (OpenSSL flavour)
p libcurl3:i386 - easy-to-use client-side URL transfer library (OpenSSL flavour)
p libcurl3-dbg - debugging symbols for libcurl (OpenSSL, GnuTLS and NSS flavours)
p libcurl3-dbg:i386 - debugging symbols for libcurl (OpenSSL, GnuTLS and NSS flavours)
v libcurl3-dev -
v libcurl3-dev:i386 -
i A libcurl3-gnutls - easy-to-use client-side URL transfer library (GnuTLS flavour)
p libcurl3-gnutls:i386 - easy-to-use client-side URL transfer library (GnuTLS flavour)
v libcurl3-gnutls-dev -
v libcurl3-gnutls-dev:i386 -
p libcurl3-nss - easy-to-use client-side URL transfer library (NSS flavour)
p libcurl3-nss:i386 - easy-to-use client-side URL transfer library (NSS flavour)
v libcurl3-nss-dev -
v libcurl3-nss-dev:i386 -
v libcurl3-openssl-dev -
v libcurl3-openssl-dev:i386 -
v libcurl4-dbg -
v libcurl4-dbg:i386 -
v libcurl4-dev -
v libcurl4-dev:i386 -
p libcurl4-doc - documentation for libcurl
p libcurl4-gnutls-dev - development files and documentation for libcurl (GnuTLS flavour)
p libcurl4-gnutls-dev:i386 - development files and documentation for libcurl (GnuTLS flavour)
p libcurl4-nss-dev - development files and documentation for libcurl (NSS flavour)
p libcurl4-nss-dev:i386 - development files and documentation for libcurl (NSS flavour)
p libcurl4-openssl-dev - development files and documentation for libcurl (OpenSSL flavour)
p libcurl4-openssl-dev:i386 - development files and documentation for libcurl (OpenSSL flavour)
p libcurlpp-dev - c++ wrapper for libcurl (development files)
p libcurlpp-dev:i386 - c++ wrapper for libcurl (development files)
p libcurlpp0 - c++ wrapper for libcurl
p libcurlpp0:i386 - c++ wrapper for libcurl
/opt/dev/easycwmp$ ./configure --enable-debug --enable-devel --enable-acs=multi --enable-jsonc=1
configure: WARNING: unrecognized options: --enable-acs
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking dependency style of gcc... (cached) gcc3
./configure: line 4106: syntax error near unexpected token `LIBCURL,'
./configure: line 4106: `PKG_CHECK_MODULES(LIBCURL, libcurl)' - There is error!
I did install

  - pkg-config
  - libssl-dev

As seen on other page, but does not work.

I don't know what to do anymore.
No tags attached.
Issue History
2018-09-11 21:53hendreNew Issue
2018-09-12 15:39mohamed.kallelNote Added: 0000912

Notes
(0000912)
mohamed.kallel   
2018-09-12 15:39   
check if you have libcurl installted on your ubuntu system.
if it's already installed, may be you have some dependencies missinig