EasyCwmp - easycwmp
View Issue Details
0000216easycwmp[All Projects] Helppublic2017-04-21 03:402017-04-24 13:10
andy_yang 
mohamed.kallel 
immediateblockalways
resolvedno change required 
linuxopenwrtopenwrt15
0000216: There is no --enable-debug and --enable-devel options when I build easycwmp on the openwrt15
when I build easycwmp by use following command:
make package/easycwmp/compile V=99

I find that configure there is --enable-debug and --enable-devel options.But the Makefile have define the two options:

PKG_CONFIG_DEPENDS:= \
        CONFIG_EASYCWMP_DEBUG \
        CONFIG_EASYCWMP_DEVEL
...
ifeq ($(CONFIG_EASYCWMP_DEBUG),y)
CONFIGURE_ARGS += \
        --enable-debug
endif

ifeq ($(CONFIG_EASYCWMP_DEVEL),y)
CONFIGURE_ARGS += \
        --enable-devel
endif
message is as following:
.....
 ./configure --target=arm-marvell-linux-uclibcgnueabi --host=arm-marvell-linux-uclibcgnueabi --build=i686-linux-gnu --program-prefix="" --program-suffix="" --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/lib --sysconfdir=/etc --datadir=/usr/share --localstatedir=/var --mandir=/usr/man --infodir=/usr/info --disable-nls --with-uci-include-path=/disk2/yang.yong/work/develop/VIX10/mv6560/openwrt/staging_dir/target-arm-marvell-linux-uclibcgnueabi/usr/include --with-libubox-include-path=/disk2/yang.yong/work/develop/VIX10/mv6560/openwrt/staging_dir/target-arm-marvell-linux-uclibcgnueabi/usr/include --with-libubus-include-path=/disk2/yang.yong/work/develop/VIX10/mv6560/openwrt/staging_dir/target-arm-marvell-linux-uclibcgnueabi/usr/include --enable-jsonc=1 ; fi; )
....
I doubt that the define PKG_CONFIG_DEPENDS don't be included by openwrt rule.
No tags attached.
rar compile_log_and_Makefile.rar (1,144) 2017-04-21 03:40
http://support.easycwmp.org/file_download.php?file_id=98&type=bug
Issue History
2017-04-21 03:40andy_yangNew Issue
2017-04-21 03:40andy_yangFile Added: compile_log_and_Makefile.rar
2017-04-21 03:42andy_yangNote Added: 0000687
2017-04-21 10:34mohamed.kallelNote Added: 0000688
2017-04-24 03:11andy_yangNote Added: 0000689
2017-04-24 13:10mohamed.kallelStatusnew => resolved
2017-04-24 13:10mohamed.kallelResolutionopen => no change required
2017-04-24 13:10mohamed.kallelAssigned To => mohamed.kallel

Notes
(0000687)
andy_yang   
2017-04-21 03:42   
there is a line errror in the Description :
I find that configure there is --enable-debug and --enable-devel options.
it should be :
I find that configure there is no --enable-debug and --enable-devel options.
(0000688)
mohamed.kallel   
2017-04-21 10:34   
Did you select debug options in the make menuconfig ---> utilities --> easycwmp ?
(0000689)
andy_yang   
2017-04-24 03:11   
Oh, it's my careless. Thanks for your help!